Strange PC resource usage

Guides for installation, patching and more
Post Reply
Surena
Posts: 3
Joined: Mon Nov 27, 2017 3:18 pm

Strange PC resource usage

Post by Surena » Thu Mar 15, 2018 2:52 pm

I have been testing IV-MP T4 for the last two days and unfortunately, I have to mention a strange issue about the way T4 uses PC resources to run the game.

PC specs:
CPU: AMD A10-7850K @ 4,3GHz 1.38v
RAM: 12GB DDR3 @ 1866MHz 1.5v
MOBO: Asus A88XM-PLUS FM2+
GPU: AMD Radeon R9 290 @ 1000MHz Core & 1250MHz Mem - Stock voltage
PSU: Corsair VS550 550 Watts ATX

The issue
Basically, when I go in Story Mode (Singleplayer) my CPU will peg at 99%, which is also the case with IV:MP T3,
while my CPU is "limited" (?) to 50-55% max usage.

Performance, or lack thereof...
The combination of a low IPC (Instructions Per Clock) CPU with a high-end GPU that really needs the CPU at max load to get decent framerates. This results in the framerate not exceeding 25FPS+ at 50% CPU load, and frame time being above 30ms which is also crap if you find out how terrible the input lag is.

Solutions
The only two solutions that would help are 1. Buying a faster CPU or 2. Overclocking the CPU to minimize the CPU bottlenecking the GPU, however, if the CPU runs at 50-60% load then it won't boost to the max overclock set, thus the whole overclocking being pointless.

Results
The highest FPS I have seen was 38FPS at Hove Beach and Booth Tunnel, and with the same situation in IV:MP T3 I would get over 120FPS. Average FPS was around 19FPS in T4 while being around 40-60FPS in T3 respectively

Conclusion
I would blame EFLC, mods and such, however, since story mode works just fine I guess its an IV-MP T4 issue.

P.S: I have asked other players about their CPU usage and it seems they aren't getting more than 50-60% load either.

EDIT: I have also tested T4 on an i7 4790 which has a much higher IPC, thus better overall speed and the usage was the same albeit the IPC helping a lot with maintaining a good framerate at 50-60% load.


Is this issue happening because IV-MP T4 is still in development and is still being worked on at kernel level?

Armelin
Posts: 19
Joined: Sun Jul 30, 2017 4:28 am

Re: Strange PC resource usage

Post by Armelin » Thu Mar 15, 2018 5:00 pm

Consider this: you own a Quad-Core CPU and the T4 Client only uses 1 thread. Therefore the maximum CPU usage the Client can have is 25%.

You also mentioned that your single player is peaking at 99% so you should problably check if there is something wrong with your game version.

Surena
Posts: 3
Joined: Mon Nov 27, 2017 3:18 pm

Re: Strange PC resource usage

Post by Surena » Thu Mar 15, 2018 5:14 pm

Armelin wrote:
Thu Mar 15, 2018 5:00 pm
Consider this: you own a Quad-Core CPU and the T4 Client only uses 1 thread. Therefore the maximum CPU usage the Client can have is 25%.

You also mentioned that your single player is peaking at 99% so you should problably check if there is something wrong with your game version.
My CPU has two modules with 2 threads each. In Intel terms this means 2 cores and 4 threads.
It scores about 332cb in Cinebench multithread test compared to 762cb score with an i7 4790 CPU.

And about the 99% peak, thats because my CPU is a bottleneck for my GPU, meaning my CPU cannot keep up with the faster graphics card. Bottlenecking explained as fast as possible.

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests